- The / MySQL program use to run at a good speed on this computer.

- The program only runs EXTREMELY slow when it runs a MySQL Query.

- Currently the user finds it quicker to remote desktop into another computer and run the program there then it is to run the program on her local machine.

This is what I've done so far:
- Restarted the computer.
- Ran a prior version of the same program (April 2011), same results.
- Uninstalled and reinstalled the .Net framework (and updates).
- Uninstalled and reinstalled anything MySQL related.
- Checked Windows Updates.

What I'm going to do in about a half an hour:
- Place the slow computer in my office  (that has no problem running the program) and test out the program here. This will test if it's a network/wiring problem (I doubt but I'm pulling at straws right now).

What do you suggest I could test to try to solve this problem?

asked 10/07/2011 12:14

JohnnyBCJ's gravatar image

JohnnyBCJ ♦♦

8 Answers:
If the query returns a lot of results, there might not be enough memory and the system is using the swap file. Check the available physical memory on the computer that runs slowly.

An anti-virus could also intervene on some queries. Check if that computer has the same anti-virus as the others and if it is configured properly.
JamesBurger's gravatar image


The initial queries return at most 10 records / strings of no more than 30 characters each. It's not big enough to run out of memory (Dual core 3.4 Ghz, 3.5 Gigs of RAM, Windows 7). Thanks for the suggestion!

9 out of the 10 computers are identical (Software and hardware). The odd computer is mine which does not have this problem. The computer having this problem is identical to 8 other computers that do not have the problem.

All computers have AVG installed. All have the same AVG settings.
JohnnyBCJ's gravatar image


If I run the program in safe mode (with networking), it's as slow as it is if the program is run in normal mode.
JohnnyBCJ's gravatar image


I've restored the computer as far back as I was allowed - same result.
I'm running an AVG scan now to see if it'll pick up anything.
JohnnyBCJ's gravatar image


This is probably a network problem. First check ping times to your mysql server, then you can try some trace route from your slow and fast computer, if they are the same, and if these results are the same I would try to change the network card and the socket in your switch/router.
Fugas's gravatar image


I solved this problem. I'll give the points to whoever can explain why or what could have possibly caused this happened.

I setup the slow computer in my office. Same result. There was a bunch of updates (Windows, Adobe, etc) so I installed them all. At the end of the updates I restarted the computer. When I attempted to log back into the domain an error occurred "the trust relationship between this workstation and the primary domain failed". I restarted the computer, booted in safe mode with networking and removed the computer from the domain. Restarted the computer again and added the computer to the domain. After one last restart, the program finally started to act normal speed.

What confuses me is that this computer was still able to access all the network drives that were located on the server but yet 'The trust relationship between this workstation and the primary domain failed'.
JohnnyBCJ's gravatar image


>the trust relationship between this workstation and the primary domain failed

I occasionally get that on some computers. No explanation.
CodeCruiser's gravatar image


My comment is the solution to my problem. No one gave me any information on why this happened or what could have caused this problem to occur.
JohnnyBCJ's gravatar image


Your answer
[hide preview]

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments



Asked: 10/07/2011 12:14

Seen: 785 times

Last updated: 10/21/2011 09:15